Skip to content

Netgear WNDR4500 and Cisco SPA112

So after I moved to the US I could not get my old analog phone adapter (Linksys SPA3000) to work and I just assumed that it had not survived the trip to the US. I never saw any registration attempts on my Asterisk server from the SPA3000 but both my Nokia N9 could register using SIP and so could my wife's Samsung Galaxy S3 using Sipdroid. I finally decided to buy a new phone adapter and since I have been very content with the SPA3000 I decided to go with a Cisco SPA112. Later I have found out that a lot of people really don't like either the SPA112 or SPA122. Well I fought and fought with it for days but the problem was the exact same as with the SPA3000, no registration attempts ever reached the Asterisk server. I thought it was possibly firewall issues or something similar although that made no sense since the mobile phones could register while being on the wireless network. I finally came to the conclusion that it had to be the new Netgear WNDR4500 that we also bought when we moved here. So I found the setting. Enable WMM (Wi-Fi multimedia) settings This setting seems to come enabled by default. It can be found under Advanced Tab -> Setup -> QoS Setup. I disabled that and the SPA112 registered right away and I have had no issues since. I guess either Netgear's implementation of WMM is faulty or Cisco's SIP implementation is buggy. No matter which I don't need that setting enabled and I am very happy that everything works now.


No Trackbacks


Display comments as Linear | Threaded

No comments

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.

Form options